Issue with application launch and WinRT States

Oct 8, 2012 at 12:02 PM

Hi,

I am using your Widows 8 Metro Google Analytic library in my application, But while the time of integrating the library. I am facing several issues.

1. Application Freezes on start up : For the first time of application launch, the app freezes on start up. And here after if we restart the application the application works without any issue.

2. App Crashes while coming from terminated state : While coming from terminated state the application crashes on (AnalyticsService.cs), in this scenario Windows.Current is null. So in  AttachServices() method reaches the application raises an error condition.

3. Application takes more time for suspension : It takes more than 20 sec for suspending the app, and eventually it causes the app crash

regards,

Stephe

Coordinator
Oct 11, 2012 at 7:36 PM

Hi, Stephe!

1. Did you try using latest nuget/source code?

2 and 3. Never faced this issue, we'll reproduce and fix it.

If you have any ideas on how to fix these issues, you're welcome. 

Sincerely yours,

Alex. 

Nov 15, 2012 at 3:39 PM

Hello all,

we are using your Windows 8 Metro Google Analytic library in my application. We don't had faced any drawbacks in our implementation using this library. However after some test's when we go to our google analytic account, we can't see any output, any result of our tests.

Do you know the reason of this? It could be a wrong implementation? What could be wrong? 'Cause we don't have any code error.

Thanks in advance,

Regards

Filipe

Coordinator
Nov 15, 2012 at 7:21 PM

Hi, Filipe!

I noticed same behavior and it sometimes works and sometimes not. Could not find any reason for this issue.

Anyway, next update will contain better support for GA (stable one) and it works nicely withouth any questions. We've tested it on our apps and they work good in marketplace.

Nov 19, 2012 at 2:07 PM

Hi Alex,

 That's good news. If it's a stable version, and don't have that issue anymore. What is the expectation to have a new release of this library? 

Best Regards,

Filipe

Coordinator
Nov 20, 2012 at 9:43 AM

I expect it to finish this week.

Nov 20, 2012 at 1:48 PM

Hi Alex,

   good news, very good news... 

Best Regards,

Filipe

Coordinator
Nov 25, 2012 at 11:22 PM

Filipe, we've just released new version :)

Check if it's good now for you and let me know.

Nov 27, 2012 at 9:02 AM

Hello Alex.

I've installed w8ga and fallowed the tutorial but I still can't get any results on GA.

When creating the account on GA what kind should I choose: Web Site or Mobile App?

Best Regards,

Jose Medeiros 

Nov 27, 2012 at 10:07 AM

I've figured it out!

Account: Web Site

Don't forget to call the AnalyticsHelper.TrackPageView()

It works!

Thanks alot man, great project.

Best Regards,

Jose Medeiros

Nov 28, 2012 at 10:37 AM

Hi Alex,

now it seems to work without any problem, if we detect anything or if we had any suggest, I will feel free to tell you ;).

It's a very good project, congratiulations Alex.

Regards,

Filipe

Coordinator
Nov 28, 2012 at 10:44 PM

Seems that I use old js codeform which might be not working on mobile app profiles in GA. Need to check documentation, but seems to me that it's just an option (track this app as a site, so it's still mobile app but can be tracked via site)